Reporting Lag
Incident Report for Kevel
Resolved
Yesterday successfully completed and today is in progress of catching up - things will be back to normal by afternoon and today will finish on time. Thanks for your patience.
Posted Sep 23, 2014 - 07:56 EDT
Monitoring
Due to high traffic today we are experiencing a lag in reporting numbers for today only - we are bringing on additional capacity and things should be caught up by 12:00 EST.
Posted Sep 22, 2014 - 17:52 EDT