UI Stability
Incident Report for Kevel
Resolved
We believe we have identified and resolved the issues around UI Stability. We have been closely monitoring it and haven't seen the same issues we saw in the past this week. Please get in touch if you continue to see issues where you can't login or receive an error message.
Posted Mar 14, 2014 - 09:48 EDT
Investigating
We are aware that the UI has been having multiple issues around users being able to login and random errors occurring. We are working on resolving the issue and will leave this incident open until we have it resolved.
Posted Mar 03, 2014 - 11:14 EST