Reporting Delayed
Incident Report for Kevel
Resolved
Reporting is now completely caught up and running at it's normal pace. We apologize for the inconvenience this may have caused. As part of this issue we have developed a new tool to help reporting catch up in the event it gets behind. We process almost a billion impressions a day in reporting so any interruption can cause a delay that can often takes hours or days to recover from. The new tool we created will help further compress the days data to enable us to catch up reporting in a single import as opposed to through the normal process.

Two quick notes on reporting.

1. We use a log system where every engine logs out impressions to a file that is then stored on a redundant storage system. This gives us the confidence that we are capturing every impression and never losing data as we can always compare these raw logs to reporting data to ensure consistency.

2. We are in the process of testing a new reporting system that we believe will be much faster, reliable, and will include additional data not currently tracked in reporting. We will have more news on this shortly.

Thanks again for your patience and let us know if you have any questions or concerns.
Posted Sep 17, 2015 - 07:06 EDT
Update
All data other than keyword data is now complete for 9/16. Keyword data is being loaded and will finish over the night. Keyword data is only used for forecasting by keyword or reporting by keyword. I will provide another update tomorrow when Keyword data has finished loading and provide an update on what happened and how we solved it.
Posted Sep 16, 2015 - 23:00 EDT
Monitoring
Reporting continues to be delayed, but we are running a process to catch it up in a single import. You may see odd numbers for today while this is running. We will let you know when it is done and the days data is properly loaded.
Posted Sep 16, 2015 - 20:04 EDT