Reporting Latency
Incident Report for Kevel
Resolved
The issue has been resolved.
Posted Feb 25, 2014 - 14:47 EST
Identified
We have identified an issue causing latency in reports. Reporting will be temporarily unavailable for the next 15 minutes while this is resolved.
Posted Feb 25, 2014 - 14:02 EST