Click reporting delayed
Incident Report for Kevel
Resolved
This issue has been resolved.
Posted Dec 09, 2013 - 16:23 EST
Monitoring
Click reporting is currently delayed. We are adjusting our systems to handle additional load, and are monitoring the situation. We expect this issue to be resolved shortly.
Posted Dec 09, 2013 - 15:40 EST
This incident affected: Reporting.