Ads balancing suboptimally
Incident Report for Adzerk
Resolved
All ads have been triple-checked and all systems are back to normal operation.
Posted 8 months ago. Apr 19, 2017 - 22:02 EDT
Update
Almost all ads were checked & balanced yesterday and are serving optimally again. However, a handful of ads may still be serving suboptimally so we are continuing our data check efforts today. This might cause short periods of increased latency from when a UI/API change is made and when it takes effect in the ad servers.

We continue to monitor this situation and will advise when we have triple-checked that all ads are totally back to normal. In the meanwhile, if you plan to make any larger than normal configuration changes via the management API today, please let us know at support@adzerk.com so we can properly schedule some of our server-intensive efforts.
Posted 8 months ago. Apr 19, 2017 - 11:08 EDT
Update
At this point all ads are stopping & starting correctly and any changes to your configuration via the management API or UI should take effect nearly immediately. However, our ad balancing servers (basically the brains of Adzerk's ad serving) have a large backlog of ad balancing operations that may cause some ads to serve more or less often than optimal. We are actively taking steps to catch up on this backlog as quickly as possible.
Posted 8 months ago. Apr 18, 2017 - 10:19 EDT
Update
Most customers are now data checked and ads are stopping & starting correctly now. However, a side-effect of these data checks is that there is now increased latency between when a change is made in the management UI & API and when it takes effect on the ad servers. We are continuing to monitor and manage to get change latency back to normal.
Posted 8 months ago. Apr 17, 2017 - 11:25 EDT
Monitoring
Some ads are not starting or stopping at their scheduled time. We have identified the problem and have put corrective steps in place. We are now rolling out data checks customer by customer to ensure all ads are stopped & started correctly.
Posted 8 months ago. Apr 17, 2017 - 09:06 EDT