Reporting Revenue Calculation
Incident Report for Kevel
Resolved
We have completed the restore of data for the 7th, 8th, and 9th. All network level and site level data is now complete and available. Again we apologize for the issues.
Posted Apr 10, 2015 - 17:10 EDT
Update
The data update process is running. All flat rate flights have been corrected, CPC flights are running now and CPA flights will be corrected before the morning. (CPM flights required no changes)

It is important to note that this fix will only resolve the issue when grouping by Advertiser, Flight, or Creative. If you run a network or site report it will still show incorrect revenue - this issue will be resolved tomorrow. We wanted to prioritize the fix for data that is sent to advertisers.

Thanks for your patience and please get in touch if you have any concerns or see any issues.
Posted Apr 09, 2015 - 23:42 EDT
Monitoring
Apologies for the delay in update - the deployment has completed so data being collected now is correct going forward. Things are taking longer than expected on updating the incorrect data, but we plan on having it done tonight. As a back up plan we are starting to re-process the entire data for the days in case we need to go that route.
Posted Apr 09, 2015 - 19:41 EDT
Update
The fix to the engine is 50% deployed and should finish over the next 30-45 minutes. This has been our main goal so that we know revenue numbers going into tomorrow are good.

We are working on a system to update the reporting data to ensure it is correct. We have identified that the only days with bad data are 4/7,4/8 and 4/9. We will be correcting 4/7 and 4/8 once the system is updated and tested and 4/9 will be corrected tonight once all data for the day has been loaded in.

While these updates are running you will see revenue fluctuate in reporting.
Posted Apr 09, 2015 - 16:15 EDT
Identified
We have identified the issue and the fix is two-fold. The first fix is to correct the bad data entering the system, we are pushing up a change to the engine right now that resolves this issue. The second fix is to correct the data in the system, that fix is being worked on and will be run before 5:00 EST.
Posted Apr 09, 2015 - 14:47 EDT
Investigating
Reporting is currently displaying incorrect revenue numbers for CPC and CPA campaigns. We are investigating the cause and should have a fix deployed tomorrow and will work to correct all existing data by end of day tomorrow.
Posted Apr 08, 2015 - 20:43 EDT