Reporting Service
Incident Report for Kevel
Resolved
The issue is resolved - we apologize for the inconvenience.
Posted May 16, 2016 - 17:25 EDT
Identified
We have identified the issue and a fix is in progress - should be back in 5 minutes.
Posted May 16, 2016 - 17:09 EDT
Investigating
We are investigating an issue with reports being returned from the UI and API.
Posted May 16, 2016 - 16:44 EDT