UI/API Changes delayed
Incident Report for Adzerk
Resolved
This has now been resolved.
Posted 12 months ago. Dec 16, 2016 - 18:23 EST
Identified
Changes made to ads through the UI and API are currently delayed. You can continue to make changes and they will be applied once we resolve the issue.
Posted 12 months ago. Dec 16, 2016 - 17:05 EST